Clutch Problem on G9

Information relating to the Matchless G9 or AJS Model 20 500cc twin
Member
User avatar
Posts: 18
Joined: Sat Mar 16, 2019 8:48 pm
Location: Christchurch New Zealand

Clutch Problem on G9

Postby NZMatchless » Mon Jun 17, 2019 1:37 am

I Have issues's with my G9's clutch, Ive adjusted the cable so theres a tiny bit of play but it doesnt seem to dissangege easily and seems to drag a bit once Ive got it in gear, then when I ride it, the clutch slips in thrid and forth gears, any advice?
Ride New Zealand - Live the Dream

Member
Posts: 6449
Joined: Wed Sep 01, 2004 12:00 am
Location: WEST SUSSEX UK

Re: Clutch Problem on G9

Postby SPRIDDLER » Mon Jun 17, 2019 8:28 am

The cable adjuster only adjusts the slack in the cable. It does not adjust the clutch. The clutch is adjusted at the stud and locknut in the centre of the clutch pressure plate.

Clutch slip will most likely be due to weakness or insufficient pressure of the clutch springs, a sticky clutch thrust rod or worn/contaminated/warped clutch plates or wear ridges in the clutch basket 'ears'.

Have a look here under 'Books' for your '53 model Owners Manual and Workshop Manual:

http://archives.jampot.dk/

E.g. Here's your '53 G9 Owners Manual. See clutch illustration and adjustment details on pages 40 to 42:
http://archives.jampot.dk/book/Owners_m ... ual_G9.pdf

Does the clutch slip when kick starting?
I poke badgers with spoons.

Member
Posts: 87
Joined: Mon Jan 14, 2019 5:37 pm
Location: Aberdeenshire

Re: Clutch Problem on G9

Postby Oggers » Tue Jun 18, 2019 8:28 am

Totally agree with the above, plus ensure the clutch disengages uniformly all round the circumference of the clutch plates - use the basket bolts to adjust.

Return to G9 / AJS Model 20

Who is online

Users browsing this forum: No registered users and 3 guests