Oil Return on 250cc AJS Model 14

Information relating to the Matchless G2 or AJS Model 14 250cc Lightweight
Posts: 25
Joined: Tue Aug 05, 2003 12:00 am
Location: WARWICKSHIRE UK

Oil Return on 250cc AJS Model 14

Postby JohnR » Wed Apr 25, 2007 5:25 pm

I do not appear to be getting an oil return to the tank on my Model 14. apart from pump failure does anyone have any ideas to look at first.

Deceased
User avatar
Posts: 3924
Joined: Thu Jan 01, 1998 12:00 am
Location: KENT UK

Oil Return on 250cc AJS Model 14

Postby Biscuit » Wed Apr 25, 2007 7:27 pm

I think you need to check the pump first. Remove the oil tank, remove the screw on the extreme left of the pump casting and remove the plug with 'O' ring, you can then poke your litle finger down the hole, feel the end of the pump shaft while rotating the engine, it should rotate and oscillate.

If it doesn't, and the guide pin is in place, boy you have problems.

Second thoughts John, have you removed the sump plug and checked there isn't a build up of rubbish under the scavenge uptake?

Edited by - Biscuit on 25 Apr 2007 7:41:03 PM




Posts: 25
Joined: Tue Aug 05, 2003 12:00 am
Location: WARWICKSHIRE UK

Oil Return on 250cc AJS Model 14

Postby JohnR » Wed Apr 25, 2007 8:57 pm

Hi Biscuit, thanks for your reply. Just one thing as the bike is new to me. I am correct in thinking that the return to the tank is the hole coming out of the crankcase that is facing you (looking from the side) about one inch down when you take off the oil tank cap

Deceased
User avatar
Posts: 3924
Joined: Thu Jan 01, 1998 12:00 am
Location: KENT UK

Oil Return on 250cc AJS Model 14

Postby Biscuit » Wed Apr 25, 2007 9:07 pm

From all my new found knowledge of lightweights, yes, that is the one.

The original cases on the bike I have just worked on had just a plain hole, the 'new' cases had a little copper spout.

It might be worth investigating the filter as well.

Edited by - Biscuit on 25 Apr 2007 9:09:10 PM




Posts: 25
Joined: Tue Aug 05, 2003 12:00 am
Location: WARWICKSHIRE UK

Oil Return on 250cc AJS Model 14

Postby JohnR » Fri May 18, 2007 4:43 pm

A friend in the Warwickshire section located the fault and fixed it for me. Screw holding the Guide Pin in place had become loose allowing the Guide Pin to become disengaged. We did decide to ensure that the oil pump shaft was not in itself damaged and to this end had to remove the gearbox. Sounds simple in the book but was held quite tightly and proved a pig to get back.

Deceased
User avatar
Posts: 3924
Joined: Thu Jan 01, 1998 12:00 am
Location: KENT UK

Oil Return on 250cc AJS Model 14

Postby Biscuit » Fri May 18, 2007 5:11 pm

Good John, I didn't want to say, but it seemed to be going the same way as the one I worked on, where the guide pin had been jammed on the pump shaft, stripping the teeth etc.




Return to G2 / Model 14

Who is online

Users browsing this forum: No registered users and 4 guests